Error: "Operation cancelled due to an unexpected error" when generating a support bundle
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Error: "Operation cancelled due to an unexpected error" when generating a support bundle

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Article ID: 426200

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Updated On:

Products

VMware Cloud Director VMware Live Recovery

Issue/Introduction

  • When generating a new support bundle from the VMware Cloud Director Availability (VCDA) Provider Portal, the task fails and you see an error similar to:

    Operation cancelled due to an unexpected error

  • Generating a support bundle using the command line interface on the Cloud Director Replication Management Appliance also fails, and you see an error similar to:

    /usr/bin/rpm -qi h4 /usr/bin/rpm -qa Killed

Environment

VMware Cloud Director Availability 4.x

Cause

This issue occurs when the root partition becomes full during the generation of the support bundle due to the export of the cloud service database consuming the remaining available space.

Resolution

To resolve this issue, modify the support bundle generation script to exclude select database tables that would consume a large amount of space during the database export part of the script.

  1. SSH to the Cloud Director Replication Management Appliance and log in as root.
  2. Navigate to the directory of the support bundle script:

    cd /opt/vmware/h4/bin/

  3. Take a backup of the support bundle script:

    cp support-bundle.py support-bundle.py.bak

  4. Modify the script with a text editor and navigate to the section where we dump the Cloud service database:

    dump_database('h4cloud', db_bundle_path, {
    ...

  5. Comment out the line for the task table so the section looks like the example below.

    Before modification:
    dump_database('h4cloud', db_bundle_path, {
    ...
           'task': {'*'},
    ...

    After modification:
    dump_database('h4cloud', db_bundle_path, {
    ...
           # 'task': {'*'},
    ...

    Full modified section:
    dump_database('h4cloud', db_bundle_path, {
        'peer': {'*'},
        'peer_denied_org': {'*'},
        'vcsite_tunnel': {'*'},

        'vappreplication': {'*'},
        'vmreplication': {'*', '!admin_auto_logon_count', '!admin_password',
                          '!admin_password_auto', '!admin_password_enabled',
                          '!change_sid', '!customization_script',
                          '!domain_name', '!domain_org_unit', '!domain_user_name',
                          '!domain_user_password', '!enabled',
                          '!join_domain_enabled', '!reset_password_required'},
        'vmreplication_disk': {'*'},
        'deletedreplication': {'*'},

        'replication_policy': {'*'},
        'org_policy': {'*'},

        'metainfo': {'*'},
        # 'task': {'*'},

        'recoveryplan': {'*'},
        'recoverystep': {'*'},
        'recoverystep_vappreplication': {'*'},
        'recoverystep_vmreplication': {'*'},

        'sla_profile': {'*'},
        'org_sla_profile': {'*'},
        'org_sla_profiles_link': {'*'},

        # TODO: rp_* ?
    })

  6. Save the changes to the script.
  7. Return to the VCDA Provider Portal and proceed with generating a new support bundle.

Additional Information

A minimum of 30% available disk space is recommended for support bundle generation. For more information on reclaiming disk space on VCDA appliances, see Free up VMware Cloud Director Availability appliance disk space.