VSAN Host entering Maintenance Mode via ensure accessibility, host gets stuck at 99% due to .VMEM object in "reduced availability with active rebuild "
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VSAN Host entering Maintenance Mode via ensure accessibility, host gets stuck at 99% due to .VMEM object in "reduced availability with active rebuild "

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Article ID: 426121

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Updated On:

Products

VMware vSAN

Issue/Introduction

VSAN Host entering Maintenance Mode via ensure accessibility, it gets stuck at 99% due to .VMEM object in "reduced availability with active rebuild "

 esxcli vsan debug object health summary get

Health Status                                              Number Of Objects
---------------------------------------------------------  -----------------
remoteAccessible                                                           0
inaccessible                                                               0
reduced-availability-with-no-rebuild                                       0
reduced-availability-with-no-rebuild-delay-timer                           0
reducedavailabilitywithpolicypending                                       0
reducedavailabilitywithpolicypendingfailed                                 0
reduced-availability-with-active-rebuild                                   1
reducedavailabilitywithpausedrebuild                                       0
data-move                                                                  0
nonavailability-related-reconfig                                           0
nonavailabilityrelatedincompliancewithpolicypending                        0
nonavailabilityrelatedincompliancewithpolicypendingfailed                  0
nonavailability-related-incompliance                                       0
nonavailabilityrelatedincompliancewithpausedrebuild                        0
healthy                                                                  133

Environment

VMware vSAN (All Versions)

Cause

The Object is in "reduced availability with active rebuild" prior to the host being placed in to Maintenance Mode.  When this host is placed in to MM the object data should be moved to another host but it is not able to resulting in the host being "stuck going into MM" for an extended period of time. 

Resolution

If the object is no longer needed please clean up the .vMEM Snapshot and this will allow the host to be placed in to MM. 

If the object is needed please open a new SR with Broadcom support and follow the KB Collecting vSAN support logs and uploading to Broadcom VCF Support to collect the vSAN logs and vSAN Native Trace Object and upload them to the new SR for assistance and review.