Unable to send emails in ITAM due to 5.7.54 SMTP error
search cancel

Unable to send emails in ITAM due to 5.7.54 SMTP error

book

Article ID: 426066

calendar_today

Updated On:

Products

CA IT Asset Manager CA IT Asset Manager Asset Portfolio Management CA Service Management - Asset Portfolio Management

Issue/Introduction

The following error is logged in the Local Drive\Program Files (x86)\CA\ITAM\Event Service\ITAMEventService.log.

ERROR CA.Common.Utilities.Event.EventServiceFailureNotifier - Mailbox unavailable. The server response was: 5.7.54 SMTP; Unable to relay recipient in non-accepted domain
System.Net.Mail.SmtpFailedRecipientException: Mailbox unavailable. The server response was: 5.7.54 SMTP; Unable to relay recipient in non-accepted domain
   at CA.Common.Email.SendEmail.SendEmailMessage(String SMTPServer, String fromAddress, List`1 toAddressList, List`1 ccAddressList, String subject, String body)
   at CA.Common.Utilities.Event.EventServiceFailureNotifier.NotifyEventServiceFailure(String msgBody)

This issue occurs when trying to send notifications using ITPAM.

Environment

ITAM 17.4

PAM 4.4

Cause

A configuration setting on the mail server is preventing relay from internal domains to external domains.

Resolution

Work with the mail server administrator to allow relay via the specified "From" address.

Additional Information

Finding the IT Asset Manager ITAM logs

Notification Mail not going from CA Asset Portfolio Management