vCenter Server 7.0 で infraprofile-access.*.log がローテートされない
search cancel

vCenter Server 7.0 で infraprofile-access.*.log がローテートされない

book

Article ID: 425984

calendar_today

Updated On:

Products

VMware vCenter Server

Issue/Introduction

vCenter Server 7.0 において、/storage/log/vmware/infraprofile 配下の infraprofile-access.*.log ファイルが適切にローテートされません。

これらのログファイルが蓄積し続けることで、/storage/log パーティションの容量を逼迫させる原因となる場合があります。

Environment

vCenter Server 7.0

Cause

この問題は、vCenter Server 7.0 における infraprofile サービスのログ構成の既知の不具合により発生します。

Resolution

vCenter Server 7.0 においてこの問題に対する解決策はありません。

Additional Information

ディスク容量の不足を回避するため、以下の手順で古いログファイルを安全に削除することが可能です。
この例では、14日以上経過したログを削除します。

  1. Log in to the vCenter Server via SSH as root.
  2. Run the following command to delete log files older than 14 days:
    # find /storage/log/vmware/infraprofile -mtime +14 -type f -name infraprofile-access-.*.log -delete