Ping connectivity to ESX host is lost and the error 'vSphere HA agent on this host could not reach isolation address' is reported
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Ping connectivity to ESX host is lost and the error 'vSphere HA agent on this host could not reach isolation address' is reported

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Article ID: 425948

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Updated On:

Products

VMware vSphere ESXi

Issue/Introduction

Ping connectivity to the ESX host is lost and the error 'vSphere HA agent on this host could not reach isolation address' is reported. 

The following error is recorded in `/var/log/fdm.log`:

No ping reply from <IP Address>

We seek to confirm if this is an issue originating from the ESX host side.

Environment

VMware vSphere ESX 7.x
VMware vSphere ESX 8.x

Cause

The error message refers to the "Isolation Address," an IP address used by vSphere HA to check if a host is network-isolated. By default, this is the address of the default gateway.

No ping reply from <IP Address>

 

  • The vSphere HA management agent (fdm) sends a ping to the Isolation Address every 300 seconds by default.
  • If there is no response, it retries every 1 second. The error is recorded if no response is received within 3 seconds of the initial transmission.
  • If multiple Isolation Addresses are set, pings are also sent to the other Isolation Addresses.
    If connection errors with other Isolation Addresses or other hosts in the cluster are not recorded in /var/log/fdm.log, a problem on the network path between this host and the node with the IP address recorded in the error message is suspected.
  • The agent then repeats the cycle of sending a ping (5 seconds after the first ping) and checking the response (3 seconds later).
  • When connectivity is restored, the following event is recorded:

All vSphere HA isolation addresses are reachable by host

 

Resolution


Investigate and resolve the network path issue between the ESX host and the Isolation Address recorded in the error.