Not all Kubernetes Release versions visible on supervisor after syncing content library
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Not all Kubernetes Release versions visible on supervisor after syncing content library

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Article ID: 425905

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Updated On:

Products

VMware vSphere Kubernetes Service

Issue/Introduction

Customer was trying to upgrade the guest cluster to v1.32.7, but Kubernetes Release was not present for that version.

Environment

vCenter 8.0 U3 and VKS Supervisor

Cause

Possible  corruption of the  content library record or template means that the image is not security compliant and the Kubernetes Release is not correctly synchronized in VKS.

 

Resolution

If the Kubernetes Release is not showing using the command. In this case the version is "1.32.7"

kubectl get  kr -A | grep -E "NAME|1.32.7"

In the vSphere Client, check the entry in the Content Library for that version to see if it is not "Security Compliant".

Please contact VMware Support as the resolution requires ssh access to vCenter and possibly the Supervisor Control Planes.

Additional Information

 

The steps to clean up and sync the kubernetes release are based on KB 307167 : Failed to delete the content library item via vSphere web client