'Edge NIC リンクの停止状態'アラームが3秒間オープンする事象
search cancel

'Edge NIC リンクの停止状態'アラームが3秒間オープンする事象

book

Article ID: 425857

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

免責事項: これは英文の記事 「The alarm 'Edge node NIC eth0 link is down' opens and resolves after 3 seconds.(380983)」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

  • 'Edge NIC リンクの停止状態' アラームがオープンします。
  • 対象アラームがオープンした3秒後にリンクダウンが解消します。
  • しかし、vSphere 上では NSX edge の NIC はダウンしていません。
  • syslog に以下ログが出力されております。

/var/log/syslog
yyyy-mm-ddThh:mm:ss.sssZ <edge-name> NSX 1162 - [nsx@6876 comp="nsx-edge" subcomp="nsx-sha" username="nsx-sha" level="CRITICAL" eventFeatureName="edge_health" eventType="edge_nic_link_status_down" eventSev="critical" eventState="On"] Edge node NIC eth0 link is down.
yyyy-mm-ddThh:mm:ss.sssZ <edge-name> NSX 1162 - [nsx@6876 comp="nsx-edge" subcomp="nsx-sha" username="nsx-sha" level="CRITICAL" eventFeatureName="edge_health" eventType="edge_nic_link_status_down" eventSev="critical" eventState="Off"] Edge node NIC eth0 link is up.

 

Environment

  • VMware NSX-T Data Center (3.x)
  • VMware NSX (4.x)

Cause

 "sudo cat /sys/class/net/eth0/operstate"の実行に失敗していることが原因です。
NSX edge の "/var/log/syslog"に以下が出力されています。

 

yyyy-mm-ddThh:mm:ss.sssZ <edge-name> NSX 1225 - [nsx@6876 comp="nsx-edge" subcomp="nsx-sha" username="nsx-sha" level="INFO" s2comp="fork-executor-1"] Exception caught when running cmd '{'cmd': ['sudo', 'cat', '/sys/class/net/eth0/operstate'], 'input': None, 'shell': False, 'timeout': 4, 'check_return': True, 'env': None, 'type': 0, 'proc_tree': True, 'timestamp': 392962.240507027, 'seq': 106666}': {'seq': 106666, 'type': 0, 'executor': 1, 'timestamp': 392962.24113893, 'execute_time': 10.7467318289564, 'stdout': b'up\n', 'stderr': b'', 'exception': TimeoutExpired(['sudo', 'cat', '/sys/class/net/eth0/operstate'], 4)}

Resolution

'sudo cat /sys/class/net/eth0/operstate' の実行に失敗するか実行結果が'down'であった場合リンクダウンアラームがオープンします。
対象コマンドの実行に失敗した場合、その時点の NSX edge の状態が不安定であることを示します。

一時的なCPU競合やストレージパフォーマンスの低下など、インフラストラクチャの問題がないかご確認ください。
不安定な状態の原因を特定する際にサポートが必要な場合は、Broadcomサポートにお問い合わせください。