Problem:
Clicking on any computer under the All Comptuers icon yields the following error:
Internal Error - Exception Caught by Server [SDM000036]
<Please see attached file for image>
Right clicking on a computer and selecting Delete yields the following error:
<Please see attached file for image>
Environment:
CA Client Automation - All Versions
Cause:
These kind of errors can be the result of upgrading the Domain Manager Server but failing to successfully upgrade the mdb.
Run the following SQL statement in SQL Management Studio against the mdb to check the version of the mdb:
select * from ca_settings where set_id=903
<Please see attached file for image>
The output here shows the database is at the 12.9 Version.
Resolution:
Upgrade the mdb
1.Copy the ITCM Media to the Server hosting the mdb
2.Stop CAF on the Domain Manager as well as any other application services that use the mdb.
3.Backup the mdb and then run setup and select to install the mdb.
Additional Information:
Please see the Client Automation Implementation Guide at \DOC\ITCM_Impl_ENU.pdf for more information on upgrading.
For version R14 Please see the docops page below also accessible by pressing F1 from the DM.
https://docops.ca.com/ca-client-automation/14-0/en