caperfcenter_console service fails to start with a timeout error.
search cancel

caperfcenter_console service fails to start with a timeout error.

book

Article ID: 425739

calendar_today

Updated On:

Products

Network Observability

Issue/Introduction

The caperfcenter_console server fails to start with a Failed with result 'timeout'. error message. 

 systemd[1]: caperfcenter_console.service: start operation timed out. Terminating.
 systemd[1]: caperfcenter_console.service: Failed with result 'timeout'.

Environment

DX NetOps Performance Center: 24.3, 25.4

Cause

The SSL certificate was generated incorrectly causing issues with DM connecting to the console service. The DMService.log file showed the following errors:

INFO   | jvm 1    | 2026/01/05 15:37:35 | Caused by: javax.net.ssl.SSLHandshakeException: Remote host terminated the handshake

Resolution

1. Reset the SSL Configuration: Use SslConfig to disable and then re-enable HTTPS. 

2. If a specific keysize if required (2048), use the following command to generate a new keypair:

keytool -genkeypair -alias capc -keyalg RSA -keysize 2048 -storetype JKS -keystore keystore -validity 365 -ext san=dns:yourdomain.com

3: Update Truststore: Export the new key from the keystore and import that into the Truststore.

4. Import the Signed Certificates: Generate a Certificate signing request (CSR).

        Import the CA-Signed Certificate into the keystore.

        Import necessary Root and intermediate certificates into the keystore.

5. Restart NetOps portal services.