CASM Reports API not returning data for getReportsCodes
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CASM Reports API not returning data for getReportsCodes

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Article ID: 425719

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

When trying to get the available reports codes with description using the GET getReportCodes operation, no data is returned.
 
Operation is successful but returns an empty result.
 
casm_reports table is created but it's empty.

Environment

Service Management 17.4 RU4 and later

Cause

There are missing 17.4. RU4 post-install steps. This occurs when selecting No for automating the post-install steps while running the installer wizard or if there is a problem when running automated post-install steps.

Resolution

Implement the post-install steps noted in the following link:

Post-Installation Tasks for CA Service Management (Conventional) 17.4.4.0

or

Post-Installation Tasks - CA SDM Advance Availability 17.4.4.0

Note: The post-install includes loading via pdm_load the r17_4_04_insert.dat file. This file insert the OOTB reports into the casm_reports table.

Additional Information

Generating CASM Reports with APIs