HCX アラート : "Unable to publish HCX telemetry. Please check connectivity to vcsa.vmware.com"
search cancel

HCX アラート : "Unable to publish HCX telemetry. Please check connectivity to vcsa.vmware.com"

book

Article ID: 425592

calendar_today

Updated On:

Products

VMware HCX

Issue/Introduction

免責事項:これは英文の記事「HCX Alerts: "Unable to publish HCX telemetry. Please check connectivity to vcsa.vmware.com"」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

  • HCX Manager UI の [アラート] に、次の警告が表示されます。

Unable to publish HCX telemetry. Please check connectivity to vcsa.vmware.com/ph/api/hyper/send/?_v=1.0&_c={collectorId}&_i={instanceId}

  • 同様のトリガーされたアラームが vCenter UI にも表示されます。

  • /common/logs/admin/app.log に次のエラーが記録されます。
<timestamps> [MetricsCollectionService_SvcThread-40, Ent: HybridityAdmin, , TxId: #######-####-####-####=###########] ERROR c.v.vchs.hybridity.ph.PhConnection- Error uploading the file:/common/upload/metrics/PHONE_HOME/NetworkingLifecycleService/<filename>.json to the Phonehome{"status":"FAILURE","failure":"ConnectTimeoutException","details":"org.apache.http.conn.ConnectTimeoutException: Connect to vcsa.vmware.com:443 [vcsa.vmware.com/#.#.#.#] failed: connect timed out

<timestamps> UTC [MetricsCollectionService_SvcThread-40, Ent: HybridityAdmin, , TxId: #######-####-####-####=###########] INFO  c.v.vchs.hybridity.ph.PhConnection- vCenter Server alert published for Telemetry communication status, event code: com.vmware.hcx.communication.TelemetryNotReachable , vCenterInstanceId: ########-####-####-####-############

Environment

VMware HCX

 

Cause

HCX Manager は、アプライアンス管理インターフェイス (https://hcx-ip-or-fqdn:9443) の [構成] -> [カスタマー エクスペリエンス改善プログラム] から CEIP (カスタマー エクスペリエンス改善プログラム) を使用するように構成されていますが、HCX が収集した情報を vcsa.vmware.com に送信できません。

Resolution

CEIP に参加している HCX サイトの場合、境界ファイアウォールで vcsa.vmware.com への接続を許可する必要があります。「Network Port and Protocol Requirements」を参照してください。

ネットワーク接続をテストするには、HCX Manager に管理者として SSH 接続し、次のコマンドを実行します。
curl -kiv https://vcsa.vmware.com
注: アプライアンス管理インターフェイス (<https://hcx-ip-or-fqdn:9443>) で [管理] -> [ネットワーク設定] -> [プロキシ] の順に選択してプロキシが設定されている場合は、このプロキシでこの接続が許可されていることを確認してください。

回避策:
HCX Manager インターフェイスでオプションを選択することで、いつでもプログラムから脱退できます。詳細については、「Leave or Join the HCX Customer Experience Improvement Program」を参照してください。

注: CEIP から脱退すると、HCX WAN 最適化 (WAN-OPT) サービスを含むすべての分析ベースのプログラムが無効になります。WAN 最適化は、データ削減、圧縮、回線調整を提供します。このサービスを使用するには、CEIP への参加が必要です。

Additional Information

About the Customer Experience Improvement Program