SNMP v3 device discovery fails with error: SNMP-E-EUSMUSER-[USM]: Unknown User Name
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SNMP v3 device discovery fails with error: SNMP-E-EUSMUSER-[USM]: Unknown User Name

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Article ID: 425589

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Updated On:

Products

VMware Smart Assurance Network Observability

Issue/Introduction

Discovery of SNMPv3 device fails with the error on Smarts IP Domain Manager:

No response from SNMP agent, V3, SNMP-E-EUSMUSER-[USM]: Unknown User Name

Environment

All Supported Smarts releases

Cause

The error "No response from SNMP agent, V3, SNMP-E-EUSMUSER-[USM]: Unknown User Name" indicates a problem with the User-based Security Model (USM), most commonly that the SNMPV3 username (security name) is unknown to the receiving device or that the credentials do not match. 

Resolution

Verify if the credentials used to discover the device.

If the credentials are valid, please collect the following data and raise a support request with the Broadcom Support.

  • Enable TCPDump data :
    sudo tcpdump -i <interface name> -v -s 0 -w tcpdump.pcap host <Remote Host> and port <Port>
  • Run the discovery of the device 
  • Once the discovery completes, stop the TCPDump using CTRL + C and collect the tcpdump.pcap file.