UNKNOWN_SYSTEM_ERROR in Stage 1 Step 4 (validateupdateproductcertifcate) during Replace Certificate Request for Identity Manager
search cancel

UNKNOWN_SYSTEM_ERROR in Stage 1 Step 4 (validateupdateproductcertifcate) during Replace Certificate Request for Identity Manager

book

Article ID: 425544

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

When replacing the vIDM certificate via Aria Suite Lifecycle Manager, the Node Snapshot Requirement step fails with:

  • UNKNOWN_SYSTEM_ERROR
  • Unknown system error.
  • Password with vmid ##### does not exist

Environment

Aria Suite Lifecycle 8.18.5
Identity Manager 3.3.7

Cause

This occurs because of an issue with the password records in the locker compared to what is configured in the vIDM globalenvironment object.

Resolution

Option 1

Resolve the issue with the password associated with the vIDM instance utilizing the locker and modifying the environment for the vIDM instance to be updated with the correct locker entry. See Additional Information below for VCF environments.

Option 2

  1. Gracefully shutdown the vIDM nodes via Aria Suite Lifecycle Manager's Power OFF option from within the ellipses menu for VMware Identity Manager.
  2. When the nodes are powered off, take a snapshot of each via vCenter vSphere Client.
  3. Use Aria Suite Lifecycle Manager to Power ON the environment.
  4. Retry the Replace Certificate Request and do not choose to Opt-in for Snapshot (A rollback point is now already available).

Additional Information

Please see Aria Automation Inventory Sync Fails because a password does not exist - displaying Error Code: LCMVCF19102 for more information on how this may occur in a VCF deployment.