CASM Reports API is unavailable
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CASM Reports API is unavailable

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Article ID: 425532

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

When trying to access to the CASM Reports API, it does not work or respond. (default URL: http(s)://HOST_NAME:REPORTING_PORT/CASMReports/reports/api )

Additionally, the CASMReports location does not exists or does not have files/folders (default path: NX_ROOT\bopcfg\www\CATALINA_BASE_RPT )

Environment

Service Management 17.4 RU4 and later

Cause

The reporting tool has not been deployed.

Resolution

To configure it in your App server(s), you would need to check "Configure Reporting Service" and ensure the ports configured are available in that server.

1. In an Application or primary server, run pdm_configure

2. Go through the wizard. The "Reporting Service" option shows up after connecting to the database.

3. In the "Reporting Service" page, check the "Configure Reporting Service" and set the tomcat port numbers

Note: The Reporting Service option is available only in the Application servers in an Advanced Availability environment. 

Additional Information

Generating CASM Reports with APIs