Duplicate workflow execution in VMware Aria Automation after vCO pod restart
search cancel

Duplicate workflow execution in VMware Aria Automation after vCO pod restart

book

Article ID: 425478

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

In a clustered VMware Aria Automation environment, you may encounter an issue where a single workflow run executes simultaneously on two different nodes.

This behavior typically occurs under the following conditions:

  • The workflow contains a User Interaction element.

  • The pod/node originally executing the workflow (Node 1) restarts while the workflow is in a 'waiting' state.

  • A different node (Node 2) resumes the workflow after the user interaction is completed.

  • Node 1 completes its restart and resumes the same workflow, resulting in duplicate execution.

Environment

VMware Aria Automation 8.18.x

VCF9.x

Cause

When a workflow wakes up from a User Interaction state, the database does not correctly update the owner field to the node currently executing the task. If the original owner node reboots, it references the database and resumes all workflows it believes it still owns, unaware that another node is already processing them.

Resolution

This issue is currently under review by VMware Engineering and the fix is tentatively planned for inclusion in next release of VMware Aria Automation/Orchestrator and VCF9.