Unable to take a quiesced snapshot for a Windows VM.
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Unable to take a quiesced snapshot for a Windows VM.

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Article ID: 425399

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Updated On:

Products

VMware vSphere ESXi VMware vCenter Server

Issue/Introduction

After taking a quiesced snapshot, the “Quiesce guest file system” field still shows “No”, indicating that the snapshot is not quiesced.

Environment

  • vCenter Server 8.x.
  • vSphere ESXi 8.x.

Cause

  • The following key services are required to perform a quiesced snapshot in Windows:
    • Virtual Disk.
    • VMware Alias Manager and Ticket Service.
    • VMware SVGA Helper Service.
    • VMware Snapshot Provider.
    • VMware Tools.
  • In Windows, when navigated to "Services", VMware Snapshot Provider service was missing in the affected VM as seen from the below screenshot:

Resolution

Below are the steps to resolve the issue:

1. Click on the Search icon within the Guest OS.

2. Type appwiz.cpl and hit the Enter key.

3. Click on the VMware Tools program and select Change option.

4. Click on Next and Select Repair.

5. Click on Repair.

6. Click on Finish to exit from the VMware Tools Wizard.

7. Verify if the VMware Snapshot Provider Service is present in Windows Services by clicking on the Search icon within the Guest OS and type services.msc.

8. Retry the quiesced snapshot operation.

 

Note: A prompt to reboot the VM may appear. You can defer it, if a retried quiesced snapshot succeeds otherwise, a reboot will be required.