Cannot login to IGA Xpress right after installation: "Username/Password is Invalid"
search cancel

Cannot login to IGA Xpress right after installation: "Username/Password is Invalid"

book

Article ID: 425358

calendar_today

Updated On:

Products

CA Identity Suite

Issue/Introduction

After installation igx user cannot login to IGA Xpress with the known password.

Attempts to change credentials in Linux via passwd igx command or for the installation via igactl passwdxp commands do not lead to a solution of the problem.

Attempts to remove /opt/brcm/iga/xpress_conf/auth.json to revert from application authentication to native Linux authentication also make no effect.

Xpress log (xpress.log) contains the following lines:

binascii.Error: Invalid base64-encoded string: number of data characters (45) cannot be 1 more than a multiple of 4
Missing/Incorrect cluster key

 

Environment

IGA Xpress 1.0.5

Cause

Deviations from the standard installation process.

Resolution

Set new cluster key.

Use the following commands to regenerate and reset the cluster key:

cluster_key --gen
cluster_key --set

Then restart IGA Xpress using one of the following commands:

igactl restart xpress
igactl cluster restart xpress