Cannot edit Service Mesh to remove WAN-OPT appliance
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Cannot edit Service Mesh to remove WAN-OPT appliance

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Article ID: 425304

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Updated On:

Products

VMware Cloud on AWS

Issue/Introduction

When attempting to Upgrade HCX to version 4.11.3 the error that WAN-OPT must be removed may be encountered.  In the VMC Console the error will look like this:

However when attempting to edit the Service Mesh the "edit" button will be grayed out, despite being logged in using the [email protected] account.

Environment

VMC on AWS

VMware HCX

Cause

This is a result of the Site Pair being established from the Connector (on-prem) side of the connection to the Cloud (VMC on AWS) environment.  Within the HCX Manager UI you can confirm by verifying the direction of the pairing (which direction the arrow points).

Resolution

  • Access the HCX Connector Manager UI
  • Edit the Service Mesh and remove the WAN-OPT service
  • Remove WAN-OPT from the Compute Profile within the HCX Connector UI
  • Sign into the HCX Cloud Manager UI
  • Remove the WAN-OPT from the Compute Profile
  • Proceed with the upgrade