PPM-025 error on configuring snmpcollector in Admin Console
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Article ID: 4252
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Updated On:
Products
DX Infrastructure ManagementNIMSOFT PROBES
Issue/Introduction
When trying to save changes for snmpcollector in Admin Console, the error PPM-025 shows itself consistently.
Cause
Residual or corrupt template files cause error accessing snmpcollector Template Editor
Environment
Release: CNMSPP99000-8.2-Unified Infrastructure Mgmt-Server Pack-- On Prem Component:
Resolution
FOR SNMPCOLLECTOR 2.X, THE FOLLOWING WILL NEED TO BE PERFORMED
Deactivate snmpcollector probe and pollagent probe on snmpcollector hub in Infrastructure Manager
Delete the snmpcollector and pollagent probes.
RDP to the snmpcollector hub robot.
Delete the snmpcollector and pollagent probe folders (this removes old templates)
Restart the robot
Install the snmpcollector and pollagent probes as new.
FOR SNMPCOLLECTOR 3.X, THE FOLLOWING WILL NEED TO BE PERFORMED
Deactivate ppm/snmpcollector and baseline_engine on the snmpcollector hub.
Rename the entire snmpcollector folder to snmpcollector_bkp, so that we have backup copies of the config files and templates.
Delete ppm folder.
Rename the baseline_engine cache_dir to cache_dir_old. This clears the cache on baseline_engine.
Deleted ppm and snmpcollector probes from IM.
Redeploy ppm/snmpcollector.
Activated baseline_engine, so that the cache_dir gets recreated.
In the newly created snmpcollector folder structure, highlighted the following files/folders and Copy/Paste these to get a backup of these in case issues arose with corruption in the files:
snmpcollector.cfg bulk_config
Replace snmpcollector,cfg and bulk_config with the backups in the new folder structure.
Deactivate/activate snmpcollector for the files to take effect.
Sign out and back into Admin Console.
It may also be necessary to clear the browser cache for the issue to be corrected.