VCF Installer Workflow Fails at VCFa Deployment with 404 Error
search cancel

VCF Installer Workflow Fails at VCFa Deployment with 404 Error

book

Article ID: 425177

calendar_today

Updated On:

Products

VMware SDDC Manager

Issue/Introduction

The VCF Installer workflow fails during the VCFa (VCF Appliance) deployment stage.

The VCFa virtual machine (VM) has been deleted from the inventory.

The following error is observed in the VCF Installer GUI and the domainmanager.log:

2025-12-19T00:12:12.758+0000 DEBUG [vcf_dm,6944985c4c0200a2c0967675cca2cc04,b645] [c.v.e.s.r.c.LoggingHttpRequestInterceptor,dm-exec-28]  Request URI: https://<VCF_FLEET_MANAGER_FQDN>/lcm/request/api/v2/requests/77655565-3d93-4b26-8b6b-cf269ee1402e
>Request method: GET
>Request body:
>Response code: 404 NOT_FOUND

 

Environment

vcf 9.x

Cause

The VCF Installer task requires the VCFa virtual machine to be active and reachable to progress the workflow. Because the VM was deleted, the installer receives a 404 NOT_FOUND response when attempting to query or interact with the appliance, causing the workflow to stall.

Resolution

To workaround this issue, the failed VCFa tasks must be skipped in the VCF Installer database to allow the main installer workflow to complete. The VCFa component can then be deployed as a "Day N" activity. via this documentation VCF Management Components - Deploy Use Case

To resolve this issue, please open a case with broadcom support.