After Deleting Virtual Service the VIP is Still Responding to Ping
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After Deleting Virtual Service the VIP is Still Responding to Ping

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Article ID: 425137

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Updated On:

Products

VMware NSX

Issue/Introduction

  • After deleting, the Virtual Server Status stuck In Progress in the NSX UI
  • The load balancer previously associated with the Virtual Server no longer shows this Virtual Server in the list of associated servers.
  • Running API GET https://<NSXManagerIP>/policy/api/infra/lb-virtual-server to see current status does not report the In Progress Virtual Server in the response body.
  • With access logging enabled on the Load Balancer, there will be Virtual Server access logs printed in /var/log/lb/ - these can be found using grep -ri "<ip_of_virtual_server" /var/log/lb/

Environment

VMware NSX

Cause

The Virtual Server state was inconsistent between the NSX Manager and Edge.

Resolution

Perform a rolling reboot of the NSX Managers.

Additional Information

For more information on Load Balancer logging see Troubleshooting NSX Native Load Balancer