After upgrading vCenter server from 7x to 8.x the SSO function has stopped working
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After upgrading vCenter server from 7x to 8.x the SSO function has stopped working

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Article ID: 425077

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Error 'invalid credentials' on UI while logging the vCenter using AD credentials.
  • vCenter is out of domain.
/var/log/likewise.log:

ERROR lsass: [0x#####] Failed to run provider specific request (request code = 8, provider = 'lsa-activedirectory-provider') -> error = 5, symbol = ERROR_ACCESS_DENIED, client pid = ####

Environment

vCenter Server 7.0

vCenter Server 8.0

Cause

Stale/Manual entry added to the AD for an existing computer object with the VCSA hostname.

Resolution

1.> Delete the existing computer object with the VCSA hostname.

2.> Re-join the domain using cli 

      /opt/likewise/bin/domainjoin-cli join domain.com Domain_Administrator Password

3.> Run this command to restart the vCenter services or reboot the VCSA:

      service-control --stop --all
      service-control --start --all

4.> Reconfigure the identity sources 

      Go to Administration > Single Sign On > Configuration, select the Identity Source tab and reconfigure.