Call API and REST API 'scripts' requests get stuck in "Waiting for queue slot" 
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Call API and REST API 'scripts' requests get stuck in "Waiting for queue slot" 

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Article ID: 425075

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Updated On:

Products

CA Automic Workload Automation - Automation Engine

Issue/Introduction

Jobs are stuck in 'Waiting for queue slot' status despite no active executions on a Queue

When Call API or REST API 'scripts' requests are launched with the QUEUE option into a limited queue, they get stuck as soon as the queue limit is reached.
In other words, any call that has the status "Waiting for queue" is not launched anymore. When queue slots are available again, new calls do get processed.

Technically this looks like this:

Call API:

ucxbxxxc script=job.txt logon=<CLIENT>,<LOGON>,<DEPARTMENT> QUEUE=QUEUE.MAX.3

with job.txt containing:
:set &HND#=ACTIVATE_UC_OBJECT(JOBS.WIN.TEST,WAIT)

REST API:

URL: POST http://<server>:<port>/ae/api/v1/<client>/scripts

payload:
{
"script": ":set &HND#=ACTIVATE_UC_OBJECT(JOBS.WIN.TEST,WAIT)",
"queue": "QUEUE.MAX.3"
}

When a fourth job is submitted in either method it will get stuck.

Cause

DE179267

This is not related to DE161092.

Resolution

Solution:

Update to a fix version listed below or a newer version if available.


Fix version:

Component(s): Automation Engine

Automation.Engine 24.4.4 - Planned release March 2026

This release date may change. Please sign up for notifications to be updated when these releases are published following this knowledge article
https://knowledge.broadcom.com/external/article?articleNumber=142615