In the Horizon Console dashboard "Invalid Certificate Detected" dialog box appears for vCenter
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In the Horizon Console dashboard "Invalid Certificate Detected" dialog box appears for vCenter

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Article ID: 424991

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • The vCenter certificate is replaced
  • In the Omnissa Horizon dashboard, "Invalid Certificate Detected" message is seen

Environment

  • vCenter 7.x
  • vCenter 8.x
  • vCenter 9.x

Cause

When vCenter certificates are replaced, Horizon does not trust the new vCenter certificate

Resolution

  1. When Horizon Console displays an Invalid Certificate Detected dialog box, click View Certificate.
  2. Examine the certificate thumbprint in the Certificate Information window.
  3. Examine the certificate thumbprint that was configured for the vCenter Server. See Managing Certificates Using the vSphere Client and vCert - expired certificate replacement script for details.
  4. Verify that the thumbprint in the Certificate Information window matches the thumbprint for the vCenter Server.
  5. Determine whether to accept the certificate thumbprint.
Option Description
The thumbprints match Click Accept to use the default certificate.
The thumbprints do not match Click Reject. Troubleshoot the mismatched certificates. For example, you might have provided an incorrect IP address for vCenter Server.

NOTE: Take a powered off snapshots of VCs before the certificates are replaced and take snapshot of Omnissa Horizon View Server VMs also.

Contact Omnissa support for further assistance

Additional Information

Accept the Thumbprint of a Default TLS Certificate

Recovery scenarios for Horizon 8 environment