Error: "Certificate differs from the expected one" trying to repair sites after a certificate change in the cloud service in VCDA
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Error: "Certificate differs from the expected one" trying to repair sites after a certificate change in the cloud service in VCDA

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Article ID: 424924

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Updated On:

Products

VMware Cloud Director

Issue/Introduction

  • After changing the certificate in the cloud service in VMware Cloud Director Availability (VCDA) when trying to repair from the another VCDA peer you get an error:

    Certificate differs from the expected one

  • In /opt/vmware/h4/cloud/log/cloud.log on the Manager Appliance where the certificate was replaced you can see entries similar to:

    2026-01-08 11:39:05.984 DEBUG - [UI-########-####-####-####-############-######-lr] [job-2] com.vmware.h4.jobengine.JobExecution     : Task ########-####-####-####-############ (WorkflowInfo{type='repair', resourceType='site', resourceId='vcda-peer-site', isPrivate=false, resourceName='vcda-peer-site'}) completed with result PeerSiteInfo{isLocal=false, state=PeerState{incomingCommError=ApiError{code='CertificateMismatch', msg='Certificate differs from the expected one.', args=[], stacktrace='com.vmware.h4.api.error.exceptions.client.CertificateMismatchException: Certificate differs from the expected one.
            at jdk.internal.reflect.GeneratedConstructorAccessor328.newInstance(Unknown Source)
    ...
            at java.base/java.lang.Thread.run(Thread.java:840)
    '}, outgoingCommError=null}, apiPublicUrl='https://<IP for the manager where the certificate was replaced>:8048', apiVersion='4.7', buildVersion='4.7.x', site='vcda-peer-site', description='', apiUrl='https://tn-########-####-####-####-############.tnexus.io:8048/', apiThumbprint='SHA-256:###############################################################################################'}

 

Environment

VMware cloud Director Availability 4.7

Cause

This issue occurs because the "https.public.address" in the Cloud Service configuration file is not populated.

Resolution

To resolve this issue, contact Broadcom Support and note this Article ID (424924) in the problem description. For more information, see Creating and managing Broadcom support cases