Exporting a VM to an OVF template fails with error "File ds:///vmfs/volumes/<Datastore-UUID>/null" was not found"
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Exporting a VM to an OVF template fails with error "File ds:///vmfs/volumes/<Datastore-UUID>/null" was not found"

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Article ID: 424904

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Updated On:

Products

VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

  • Exporting a virtual machine to an OVF template from vSphere Client or ESXi host client fails with error:
    File ds:///vmfs/volumes/<Datastore-UUID>/null" was not found
    Failed to export OVF package. ThrowableProxy.cause A general system error occurred: Export operation failed.
  • The following log seen in vCenter /var/log/vmware/vpxd.log:
    info vpxd[06748] [Originator@6876 sub=Default opID=58f96da4-01] [VpxLRO] -- ERROR task-17492 -- <VM-Name> -- VirtualMachine.ExportVmLRO: vim.fault.FileNotFound:
    --> Result:
    --> (vim.fault.FileNotFound) {
    -->    faultCause = (vmodl.MethodFault) null,
    -->    faultMessage = <unset>,
    -->    file = "ds:///vmfs/volumes/<Datastore-UUID>/null"
  • Exporting OVF templates through OVF Tool completes successfully. For more details about OVF Tool, see OVF Tool Command Syntax to Export and Deploy OVA/OVF Packages.

 

Environment

VMware vCenter Server

VMware vSphere ESXi

Cause

This issue occurs because the Virtual Machine configuration points to an invalid or "null" backing file for a connected device, most commonly the CD/DVD Drive.

Resolution

To resolve the issue, the invalid CD/DVD drive should be removed from the VM.

  • Log in to the vSphere Client.
  • Right-click the affected Virtual Machine and select Edit Settings.
  • Locate CD/DVD Drive.
    Note: If the VM has multiple CD/DVD drives, ensure you check all of them.
  • Change the backing mode to Client Device.
  • Ensure the following checkboxes are unchecked:
    • Connected
    • Connect at power on
  • Click OK to save the changes.
  • Retry the Export OVF operation via the vSphere Client.