Why am I receiving an IBM Trust Manager error whenever I launch WebMV from my browser, and how do I fix this error?
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Why am I receiving an IBM Trust Manager error whenever I launch WebMV from my browser, and how do I fix this error?

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Article ID: 42488

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Updated On:

Products

Automation Point

Issue/Introduction

Issue: 

We are trying to enable the WEBMV functionality and are having trouble launching it from remote client machines.
This works fine on the AP Server, but from some users machines we are seeing the following error message:

"HOST CONNECTION ERROR" IBM's Client TrustManager does not allow anonymous cipher suites: SSL_DH_anon_WITH_AES_128_CBC_SHA256.

Environment:  

Windows or Linux remote client machine accessing AP Server sessions via AP Web Message Viewer using a supported browser and Java Runtime.

Cause: 

The error message indicates that you have IBM's Java Runtime Environment (JRE) installed, and this can cause a conflict with the Oracle Java runtime that we require, Oracle JRE 1.7 or 1.8.

Resolution/Workaround:

1. Uninstall the IBM Java Runtime Environment (JRE) from the client machine.

2. Uninstall the Oracle Java Runtime Environment (JRE) from the client machine.

2. Reinstall the Oracle Java Runtime Environment (JRE) on the client machine.

3. Relaunch WebMV by pointing your browser at the http://yourservername/AP/WebMVGUI.html

Additional Information:

Visit the IBM Runtimes for Java Technology portal to find instructions for uninstall the IBM JRE from your system.

Environment

Release: AP327020100-11.5-Automation Point-3270/5250 Interface Option
Component: