vCenter Log Collection status shows Failed in the VCF Operations UI
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vCenter Log Collection status shows Failed in the VCF Operations UI

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Article ID: 424877

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Updated On:

Products

VCF Operations

Issue/Introduction

The Infrastructure Operations > Configurations > Log Collection page in VCF Operations shows the vCenter failing due to the following error:

javax.net.ssl.SSLException: org.bouncycastle.tls.TlsFatalAlert: certificate_unknown(46)

Environment

  • VCF Operations 9.0.0
  • VCF Operations 9.0.1
  • VCF Operations for Logs 9.0.0
  • VCF Operations for Logs 9.0.1

Cause

VCF Operations for Logs is unable to query the status of the syslog setting in the vCenter.

Resolution

This issue is known to the Broadcom development team and will be fixed in a future version of VCF Operations for Logs.

 

Workaround - Collection Type: Direct Connected

If the option Collect logs directly into Logs cluster was selected when activating log collection, restart the VCF Operations for Logs cluster.

  1. Log in to the VCF Operations for Logs UI and navigate to Management > Cluster

  2. Click the hyperlinked Host in the Nodes table

    Note: Select the node with (ILB) next to the host name last

  3. Click Restart VCF Operations for Logs

  4. Click Restart

  5. If the cluster is multi-node, wait for the restarted node's Status to change to Connected

  6. Repeat steps 2 through 4 for the remaining nodes in the cluster

 

Workaround - Collection Type: Collector/Group

If the option Collect logs using the collector/group was selected when activating log collection, restart the vcf-log-forwarder container.

  1. Log in to the VCF Operations UI and navigate to Infrastructure Operations > Configurations > Log Collection

  2. Note the collector listed in the Collector column for the vCenter whose Status is Failed

  3. Log in to the collector noted in Step 2 as root via SSH or vSphere console

  4. Restart the vcf-log-forwarder container

    docker restart vcf-log-forwarder