Banner stating NSX Manager is currently operating without a valid license
search cancel

Banner stating NSX Manager is currently operating without a valid license

book

Article ID: 424837

calendar_today

Updated On:

Products

VMware NSX

Issue/Introduction

  • A banner like the following is posted at the top of NSX Manager UI:

Environment

NSX 4.x

Cause

  • NSX is warning that the associated Compute Manager (vCenter Server) is using a different license than expected.
  • The license assigned to the vCenter is valid, but it can be seen that the vCenter is assigned a single license such as "vCenter Server 8 Standard".  A standalone license is a standalone or per-product license.
  • However, there is also a "vSphere 8 Enterprise Plus for VCF" license available - likely currently being used for ESXi Hosts and other possible assets.
  • The expectation is that the vCenter/Compute Manager is assigned the VCF license as it will entitle all VCF 8 components.

Resolution

  • It is recommended to change the VC/Compute Manager license to use the VCF license.  This should resolve the warning as it will entitle all VCF 8 components.
    1. Go to the vCenter UI > Hamburger menu.
    2. Select Administration > Licenses.
    3. Verify available licenses and check the assigned license under Assets > vCenter Server Systems.

Please note, if NSX is being successfully licensed individually (not with VCF license) the current "single" VC licensing setup will work, and once the timer on the banner runs out, it should disappear. But this is not the recommended configuration.

Additional Information

  • The issue appears to be similar to KB 381087  but the other KB is a false positive that is resolved by upgrading to 4.2.2 or above.
  • Refer to this Technical Documentation for more details on how to assign a license to the vCenter.