TEP IP is assigned to the ESXi host but is not displayed in NSX Manager
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TEP IP is assigned to the ESXi host but is not displayed in NSX Manager

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Article ID: 424744

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Updated On:

Products

VMware NSX

Issue/Introduction

  • From the ESXi host perspective, the TEP IP address is correctly assigned, and there is no impact on data traffic.
    [root@esxi1:~] esxcli network ip interface ipv4 get
    Name   IPv4 Address    IPv4 Netmask   IPv4 Broadcast   Address Type  Gateway       DHCP DNS
    -----  --------------  -------------  ---------------  ------------  ------------  --------
    vmk0   #.#.#.#         #.#.#.#        #.#.#.#          STATIC        #.#.#.#          false
    vmk10  <TEP_IP>        #.#.#.#        #.#.#.#          DHCP          #.#.#.#          false
    vmk50  169.254.1.1     255.255.0.0    169.254.255.255  STATIC        0.0.0.0          false

     

  • In the NSX Manager UI, the tunnel status appears normal, but the TEP IP Address field does not display the assigned IP address.


  • The TEP IP is also missing when querying via the API. For details on API usage, please refer to Get a Host Transport Node's State.

    GET /policy/api/v1/infra/sites/{site-id}/enforcement-points/{enforcementpoint-id}/host-transport-nodes/{host-transport-node-id}/state


    Bad Case:
    {
      "transport_node_id" : "/infra/sites/default/enforcement-points/default/host-transport-nodes/<host-transport-node-id>",
      "host_switch_states" : [ {
        "host_switch_id" : "<host_switch_id>",
        "host_switch_name" : "DVS_NSX",
        "endpoints" : [ {
          "device_name" : "vmk10",
          "ip" : "",
          "mac" : "<mac>",
          "default_gateway" : "",
          "subnet_mask" : "<subnet_mask>",
          "label" : <label>,
          "ipv6" : {
            "ipv6" : "",
            "default_gateway" : "",
            "prefix_length" : ""
          }
        } ],
        "transport_zone_ids" : [ "/infra/sites/default/enforcement-points/default/transport-zones/<UUID>", "/infra/sites/default/enforcement-points/default/transport-zones/<UUID>" ],
        "host_switch_type" : "VDS"
      } ],
      "state" : "success",
      "details" : [ {
        "sub_system_id" : "<UUID>",
        "sub_system_type" : "LacpConfigProcessing",
        "state" : "in_progress"
      }, {
        "sub_system_id" : "<UUID>",
        "sub_system_type" : "LogicalSwitchFullSync",
        "state" : "success"
      }, {
        "sub_system_id" : "<UUID>",
        "sub_system_type" : "HostConfig",
        "state" : "success"
      } ]
    }


    Good Case:

    {
      "transport_node_id" : "/infra/sites/default/enforcement-points/default/host-transport-nodes/<host-transport-node-id>",
      "host_switch_states" : [ {
        "host_switch_id" : "<host_switch_id>",
        "host_switch_name" : "DVS_NSX",
        "endpoints" : [ {
          "device_name" : "vmk10",
          "ip" : "<TEP_IP>",
          "mac" : "<mac>",
          "default_gateway" : "",
          "subnet_mask" : "<subnet_mask>",
          "label" : <label>,
          "ipv6" : {
            "ipv6" : "",
            "default_gateway" : "",
            "prefix_length" : ""
          }
        } ],
        "transport_zone_ids" : [ "/infra/sites/default/enforcement-points/default/transport-zones/<UUID>", "/infra/sites/default/enforcement-points/default/transport-zones/<UUID>" ],
        "host_switch_type" : "VDS"
      } ],
      "maintenance_mode_state" : "DISABLED",
      "node_deployment_state" : {
        "state" : "success",
        "details" : [ ]
      },
      "deployment_progress_state" : {
        "progress" : 100,
        "current_step_title" : "Configuration complete"
      },
      "state" : "success",
      "details" : [ {
        "sub_system_id" : "<UUID>",
        "sub_system_type" : "LacpConfigProcessing",
        "state" : "in_progress"
      }, {
        "sub_system_id" : "<UUID>",
        "sub_system_type" : "LogicalSwitchFullSync",
        "state" : "success"
      }, {
        "sub_system_id" : "<UUID>",
        "sub_system_type" : "HostConfig",
        "state" : "success"
      } ]
    }

Environment

VMware NSX

Cause

This issue may occur following the resolution of DHCP server issues (associated with KB#322430). Although the TEP receives an IP address after the DHCP fix, the NSX Manager may fail to recognize the newly assigned IP address.

Resolution

Perform a configuration synchronization between the NSX Manager and the target ESXi host using the API. For details on how to use the API, please refer to Resync a Host Transport Node.

POST /policy/api/v1/infra/sites/{site-id}/enforcement-points/{enforcementpoint-id}/host-transport-nodes/{host-transport-node-id}?action=resync_host_config