NSX Global Manager System Overview page extremely slow to load or times out
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NSX Global Manager System Overview page extremely slow to load or times out

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Article ID: 424732

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Updated On:

Products

VMware NSX

Issue/Introduction

Symptoms

  • When logging into the NSX Global Manager Web UI, the System page experiences significant delays, often taking approximately 5 minutes to load. During this period, users are unable to view inventory or system configurations.
  • The following symptoms may be observed:
  • API calls to federation and site status endpoints show response times exceeding 110 seconds.
  • Intermittent timeouts for site manager queries.

Environment

VMware NSX

Cause

This issue is caused by a DNS misconfiguration on the NSX Manager. Specifically, an incorrect nameserver in the /etc/resolv.conf file causes API requests to hang while waiting for DNS resolution timeouts

Resolution

This is a condition that may occur in a VMware NSX environment due to misconfiguration of the DNS servers.

To resolve this issue, you must ensure the NSX Manager is configured with the correct, reachable DNS servers.

  1. Log in to the NSX Manager CLI as root.
  2. Verify the current DNS configuration by viewing the resolv.conf file by running the following command:
    cat /etc/resolv.conf 
  3. Identify if the primary nameserver entry is incorrect or points to an unreachable IP.
  4. Update the DNS configuration to use the correct environment-specific DNS servers by running the following command:
    1. set name-servers <new-dns-server>
    2. del name-server <incorrect-dns-server> to remove the invalid server. 
  5. Login to the NSX Global Manager UI and the response time should normal again.