Unable to access the Aria Automation UI after upgrading to a later 8.18.x version
search cancel

Unable to access the Aria Automation UI after upgrading to a later 8.18.x version

book

Article ID: 424674

calendar_today

Updated On:

Products

VCF Operations/Automation (formerly VMware Aria Suite)

Issue/Introduction

Post upgrading from a previous version of the Aria Automation 8.18.x to the later version, unable to access the web interface of Aria Automation.

The /var/log/deploy.log  on the Aria Automation node shows log snippet " Unable to read Aria Automation certificate configuration for 'lb' : Missing certificate configuration for lb " .

 

Environment

Aria Automation 8.18.x

Cause

This issue occurs due to the Certificate as the handshake fails and couldn't be parsed.

Resolution

  • Follow the steps from Replacing the vRealize Automation default SSL certificate to force the certificate installation . 

  • Try updating the certificates and forcing the current certificate chain using command : ' vracli certificate ingress --set stdin --force ' didn't work .  

  • Validate connectivity inter Aria Automation node by executing command '  openssl s_client -connect IP_addess_AriaAutomation_node :443 ' and the output returns  # Result: no peer certificate available

  • Check if the certificate for the Aria Automation has been issued by an Internal Certificate Authority.  

  • Confirm that the browser URL for the Aria Automation has no certificate loaded.  

  • Perform Inventory Sync and Retrust LB for the Aria Automation and make sure, it's successful.

  • Validate the Aria Automation LB is configured as SSL passthrough . 

  • Regenerate a new Certificate and replace certificate for the Aria Automation using the Aria Suite Lifecycle Manager by following steps from How to Replace VMware Aria Automation Certificates Using Aria Suite Lifecycle