"vSAN HCL DB up-to-date " alarm on vCenter
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"vSAN HCL DB up-to-date " alarm on vCenter

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Article ID: 424667

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

  • Seeing vSAN hardware compatibility alarm on vCenter under issues and alarms:




Environment

VMware vCenter Server 8.0

Cause

This check uses thresholds of 90 or 180 days of age to show a warning or error, respectively. Those thresholds are on the high side, and VMware recommends keeping the database updated as often as operationally possible.  
  
Note: As of version 6.7 U3 this warning will also trigger if one or more hosts are running a build of ESXi that is not on the HCL such as a pulled build or custom hot patch.

Resolution

Please follow the resolution section of this KB 326619 (vSAN HCL DB Health Check Shows Red on Fresh Deployment Without Internet Access) to resolve the issue.

Additional Information

Q: What does the vSAN HCL Health – vSAN HCL DB up-to-date check do?

This health check verifies the VMware Compatibility Guide database used for the HCL checks is up-to-date. These VCG checks are not done against the HCL on the VMware website, but rather against a copy stored on the vCenter Server.    
    
The initial release of the health feature ships with a copy of the HCL database, which was current when released. This copy of the database will become outdated over time. This is especially true as new certifications with partners get added to the VCG.    
    
Note: Hardware vendors regularly update their drivers and send them for VMware certification. Older drivers may even get removed from the VCG to reflect issues found. Therefore, it is critically important to keep the local copy up-to-date.