Issue:
When following the steps in the documentation for configuring an F5 Load Balancer to monitor the CA Service Desk Manager Health Servlet, the monitor, by default, will only look at port 80 when the current steps are followed. This will not work as the health servlet typically runs on port 8180 (or other tomcat port) when configured. Thus, the F5 Load Balancer Monitor will not act upon the response accordingly.
Environment:
CA Service Desk Manager 14.1 (Advance Availability Mode)
F5 Load Balancer
Cause:
The reason for this is because the steps do not advise to enter the health servlet port anywhere in the F5 Monitor configuration.
Resolution/Workaround:
When you create Monitor you must specify the port for the CA Service Desk Manager health servlet in the "Alias Service Port" field.
By Default its set to "*" which means "All Ports", thus it will only monitor the same ports as defined within pool (which is typically port 80 or 8080 - where users would access the CA Service Desk Manager application on an application server.
To have the F5 Monitor look at the CA Service Desk Manager health servlet, you must specify the port in the "Alias Service Port" field when creating the monitor. NOTE: You cannot set this field on an existing montior - it may only be set upon creation.
For Example - here are what the fields for a typical F5 Monitor for the CA Service Desk Manager Health Servlet looks like:
Virtual: SDMvs (ip:80, SDMpool, ...)
Pool: SDMpool (member1:80, member2:80, SDMmonitor, ...)
Monitor: SDMmonitor
Type: HTTP
Send String: GET /HealthServlet/GetHealth\r\n
Receive String: AA-Server-Status: All OK!
Receive Disable String: Quiesce time remaining
Alias Service Port: 8180
Additional Information: