HCX Manager: "Cannot login administrator@vsphere.local" due to invalid vCenter credentials.
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HCX Manager: "Cannot login [email protected]" due to invalid vCenter credentials.

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Article ID: 424608

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

VMware HCX Manager fails to authenticate to the vCenter Server. VMware Aria Operations for Logs captures the following event originating from the HCX Manager IP address <##.###.###.##> associated with the HCX appliance : "Cannot login [email protected]"

This event indicates an authentication failure due to an invalid username or incorrect password being passed by the HCX appliance.

Environment

VMware vCenter Server 8.x VMware HCX.

 

Cause

The vCenter Server service account password (e.g., [email protected]) was modified or expired, but the corresponding authentication credentials were not updated within the VMware HCX Manager appliance configuration to reflect the change.

 

Resolution

  1. Access the HCX Appliance Management interface by navigating to https://<HCX_MANAGER_IP>:9443 in a web browser.

  2. Log in utilizing the local admin account or an account assigned the Admin role.

  3. Select the Configuration tab.

  4. In the left navigation pane, select vCenter Server.

  5. On the vCenter Server configuration page, select the vCenter registration and click Edit.

  6. Input the correct vCenter Server password into the Password text box.

  7. Click Save to apply the updated credentials and re-establish the connection to vCenter.

Additional Information

Ensure the vCenter Single Sign-On (SSO) account is not currently locked out prior to updating the credentials in the HCX Manager.