DB Upgrade Error on v11.1.3
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DB Upgrade Error on v11.1.3

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Article ID: 424587

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Updated On:

Products

CA API Gateway

Issue/Introduction

Our Gateway cluster is running on version 11.1.0. There are two servers in the cluster, and both of them are using embedded databases.
The MPP has been updated to the latest version, and additionally, the PMS version has been upgraded to 2.0.
After upgrading from version 11.1.0 to 11.1.3, we attempted to upgrade the database and encountered the error 

Cause

Unable to start the server: The version mismatch between the database (version 11.1.00) and Gateway (version 11.1.3) is too great.The database version must be within two major versions of the Gateway and cannot be lower.To resolve, either upgrade the database or the Gateway.

Resolution

The customer was trying to directly upgrade from 11.1.0 to 11.1.3 which cause the primary issue , so the first thing that was needed to be done was to upgrade from 11.1.0 to 11.1.2  , After upgrading from 11.1.0 to 11.1.2, we encountered another error during the database upgrade process. The error indicated that the database was locked by the second gateway node. So after removal of the db lock the upgrade to 11.1.2 was successful and then from 11.1.2 to 11.1.3 went through as well successfully .