Inventory mappings not visible in VMware Live Site Recovery UI
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Inventory mappings not visible in VMware Live Site Recovery UI

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Article ID: 424580

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Updated On:

Products

VMware Live Recovery

Issue/Introduction

Symptoms:

  • Cannot find the Inventory Mappings in my Live Recovery UI:
  • The VMware Live Site Recovery service is not paired between the sites. When attempting to pair, the service is not visible in vSphere Client > VMware Live Site Recovery > "OPEN VMware Live Site Recovery" > click on "Actions" for the affected site pair > enter the peer vCenter details and click on "Find Services":

Environment

VMware Live Recovery 9.0.3 and above

Cause

  • Inventory mapping is a feature of VMware Live Site Recovery service, and since this service it is not paired between the two sites, the option to use it are not visible in the Live Recovery UI.

  • This can be confirmed by looking at the paired services between the two sites in vSphere Client > VMware Live Site Recovery > "OPEN VMware Live Site Recovery" > view the impacted pair here:


    As seen in the above screenshot, only the vSphere Replication service has been paired between the two sites.
  • The reason why the VMware Live Site Recovery Service is not available to be paired between the two sites is because they used different custom extension for Live Site Recovery during registration.

  • This can be verified from the Summary tab of the VAMI page of each appliance:

    Site A's VLR appliance VAMI:


    Site B's VLR appliance VAMI:
  • When pairing two site's VMware Live Site Recovery (VLSR) service, and if custom extension key is used, it is required that both site's VLSR use the same extension key.

  • Custom extension keys are used when a site is a shared recovery site, each VLSR site pair is distinguished by the custom extension. Document explaining more on this - Custom extension ID.

  • Due to this, when "Find Services" is clicked in the "Add pair" wizard, there is no peer VLSR service with the custom extension key used by the local VLSR service.

Resolution

  • The custom extension key is given during registration of the VMware Live Recovery (VLR) appliance and it is not possible to change it later on from the GUI.

  • If it needs to be changed, then the VLR appliances must be un-registered and re-registered with the right custom extension key for the VLSR service.

To resolve this issue:

  1. Remove VM replications if any. Retain the seeds if required.

  2. Break the current site pair.

  3. Log into the VAMI page of each VLR appliance and click on "Unregister".

  4. Once unregistered, re-register each of the VLR appliance to their respective vCenter and in the "Custom extension ID" for the Live Site Recovery service, enter a common custom extension.

  5. Once the appliances are registered, configure the site pair. Here it will be seen that both the "vSphere Replication" and "Live Site Recovery" service will be available to be paired.

Once both the services on both sites are paired, the inventory mapping options will be visible in VMware Live Site Recovery UI.