Intermittent L7 application failure due to ERR_INCOMPLETE_CHUNKED_ENCODING
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Intermittent L7 application failure due to ERR_INCOMPLETE_CHUNKED_ENCODING

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Article ID: 424568

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Updated On:

Products

VMware Avi Load Balancer

Issue/Introduction

Intermittent application errors may occur on an L7 VS, that relies on HTTP Chunked Transfer encoded responses. This requires Chunk merge enabled on the HTTP Application profile.

Symptoms:

  • The application may not load properly in the browser resulting in a blank page.
  • The Browser console may show the error ERR_INCOMPLETE_CHUNKED_ENCODING as seen below

Note: The Client Insights is a tech-preview feature and is not recommended for production

Ref: https://techdocs.broadcom.com/us/en/vmware-security-load-balancing/avi-load-balancer/avi-load-balancer/22-1/monitoring-and-operability-guide/application-monitoring/navigation-timing-for-client-insights.html

Environment

All Avi versions below 31.2.1

Cause

This issue may occur when the VS is configured with Client Insights.

Due to a known issue with Client Insights, when an application is using CSRF Protection feature, it may result in a blank page.

Bug ID: AV-232949

Release Notes: Using the CSRF protection feature might result in returning an empty page.

Fix version: 31.2.1

Resolution

The Client Insights feature is only tech-preview and is not recommended for production usecase. Hence if this issue occurs, the workaround is to Disable Client Insights on the VSs.

Note: This feature is disabled by default and can only be enabled via CLI from version 30.2.x