Alarm window in IM does not open / loses connectivity on secure environments (secure hub)
search cancel

Alarm window in IM does not open / loses connectivity on secure environments (secure hub)

book

Article ID: 424491

calendar_today

Updated On:

Products

DX Unified Infrastructure Management (Nimsoft / UIM)

Issue/Introduction

After Turning a hub to Secure, When logging in into the IM on that Secure hub, if "alarm Window" is requested in IM, the hubs stop responding. 

This only happens when logged on the secure hub from the secure hub local IM. When logging in to the secure hub from other non-secure hub the issue does not happen. 

Re-log in to the secure hub (127.0.0.1) fixes the issue. As soon as Alarm window is requested via IM GUI the issue reocurrs.

Environment

  • DX UIM 23.4.*
  • Secure robot and hub

Cause

Known Design Limitation of IM

Resolution

This is a known behavior, documented as well in the hub release notes for Secure Hub and Robot

 

To open the alarm console on Secure hub and robot either of the following options are available: 

 

  • Use the alarm subconsole. In IM go ot: 

    Open IM > Applications > subconsole: 

 

  • Alternatively: If you want to view the Alarm Window section in a secure environment, you can install IM on a non-secure secondary hub and point the alarm window to the primary hub nas. To do so, select Tools, Options from the menu bar and then select the primary hub nas option (for example, /<domain_name>/<primary_hub_name>/<primary_hub_robot_name>/nas) from the Alarm Server drop-down list."