グレーアウトされて「アクセス不可」のデータストアを vCenter サーバーから削除できない。
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グレーアウトされて「アクセス不可」のデータストアを vCenter サーバーから削除できない。

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Article ID: 424411

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VMware vCenter Server VMware vSphere ESXi

Issue/Introduction

免責事項: これは英文の記事 「Unable to remove inaccessible datastore from vCenter as it is grayed out.」の日本語訳です。記事はベストエフォートで翻訳を進めているため、ローカライズ化コンテンツは最新情報ではない可能性があります。最新情報は英語版の記事で参照してください。

グレーアウトされて「アクセス不可」のデータストアを vCenter サーバーから削除できない。

Environment

  • VMware ESXi 7.x
  • VMware ESXi 8.x
  • VMware ESXi 9.x

Cause

この事象は問題のデータストアにまだ仮想マシンが関連づけされている場合に見られます。(VMDK や ISO 、または他ファイル)

データストアにアクセスできないのに、仮想マシンの構成ファイルではまだデータストアを参照しているため、データストアの削除、分離ができません。

Resolution

この事象を解決するには、問題のデータストアと関連づけされている仮想マシンを確認します。もし関連のあるファイルが仮想マシンの構成にある場合は、確認後、仮想マシンから削除します。

問題のデータストアを参照している VMDK や他のファイルを外した後、ストレージリスキャンをすることでそのデータストアを削除することができます。

確認と修正のステップ

  1. vCenter サーバー UI (vSphere クライアント) で、「アクセス不可」のデータストアをクリックする。
  2. 右サイドパネルで、"仮想マシン" をクリックする。
  3. すると「アクセス不可」のデータストア上の仮想マシンが表示されます。しかし、違うデータストアで稼動している仮想マシンもリストされるかも知れません。その場合、「アクセス不可」のデータストア上の VMDK  は、'0' MB 容量として表示されます。
  4. 「構成の編集」で VMDK や CD/DVD 、ISO ファイルが関連づけされているか確認します。
    以下のスクリーンショットを参照してください。


  5. VMDK を(仮想マシンから)削除する際の影響を確認する。もしデータストアがアクセスできない状況であれば、ゲスト OS は問題のデータストア上の そのVMDK を使っていないかも知れません。
  6. 確認後、仮想マシンから VMDK は削除できます。ストレージリスキャンを実施することでで、「アクセス不可」のデータストアは消えます。

問題のあるデータストアの VMDK を削除すると、そのデータストアとの関連づけを削除するので、データストアが見えなくなるのは想定通りです。