vSphere Client becomes unresponsive and inventory browsing shows “You have no privileges to view this object or it is deleted” error.
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vSphere Client becomes unresponsive and inventory browsing shows “You have no privileges to view this object or it is deleted” error.

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Article ID: 424405

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

You can successfully log in to the vCenter Server; however, after some time, browsing the inventory displays the error:

“You have no privileges to view this object or it is deleted.”

Additional symptoms include:

  • Restarting the vpxd service temporarily resolves the issue, but the problem reoccurs after a few minutes.

  • Multiple ESXi hosts intermittently appear as Not Responding in vCenter and return to a normal state after restarting the vpxd service.

  • The vpxd.log contains multiple Failed to login on host error entries for several ESXi hosts.

    YYYY-MM-DDT04:01:17.061Z error vpxd[09534] [Originator@6876 sub=HostUpgrader] Failed to get fdm aboutInfo from host-####: N5Vmomi5Fault17HostCommunication9ExceptionE(Fault cause: vmodl.fault.HostCommunication

    --> )

    --> [context]zKq7AVECAQAAACqAeAEXdnB4ZAAAQxxTbGlidm1hY29yZS5zbwAACBhCACk/QwCWmUqBw40cAXZweGQAge6bKwGBZj1MAYHv1UsBgecDTAEC19oabGlidm1vbWkuc28AA9/GBGxpYmNzaS10eXBlcy5zbwCBfEw/AYGv+qcBgUEAqAGBsyGjAYHvUH4Cga5RfgIAB1E4AATsNwAXRTgAxQ9RBLCOAGxp

    YnB0aHJlYWQuc28uMAAF3/oPbGliYy5zby42AA==[/context] - assuming no upgrade needed

    2026-01-04T04:01:17.062Z warning vpxd[09534] [Originator@6876 sub=DAS] Failed to query FDM on host [vim.HostSystem:host-####,esxi.vsphere.local] - will try again: N5Vmomi5Fault17HostCommunication9ExceptionE(Fault cause: v

    modl.fault.HostCommunication

    --> )

    --> [context]zKq7AVECAQAAACqAeAEWdnB4ZAAAQxxTbGlidm1hY29yZS5zbwAACBhCACk/QwCWmUqBw40cAXZweGQAge6bKwGBZj1MAYHv1UsBgecDTAEC19oabGlidm1vbWkuc28AA7bDBGxpYmNzaS10eXBlcy5zbwCBj/OnAYFBAKgBgbMhowGB71B+AoGuUX4CAAdROAAE7DcAF0U4AMUPUQSwjgBsaWJwdGhy

    ZWFkLnNvLjAABd/6D2xpYmMuc28uNgA=[/context]

    YYYY-MM-DDT04:01:17.064Z info vpxd[09534] [Originator@6876 sub=DAS] Updated host [vim.HostSystem:host-####,esxi.vsphere.local] in monitor sync list, attemptNum = 18

    YYYY-MM-DDT04:01:17.064Z info vpxd[09534] [Originator@6876 sub=Vmomi] Creating SOAP stub adapter for /fdm on esxi.vsphere.local:443

    YYYY-MM-DDT04:01:17.069Z info vpxd[09534] [Originator@6876 sub=vmomi.soapStub[3538]] SOAP request returned HTTP failure; <<io_obj p:0x00007f9965633ff8, h:82, <UNIX ''>, <UNIX '/var/run/envoy-hgw/hgw-pipe'>>, /hgw/host-####/fdm>, method

    : login; code: 503(Service Unavailable); fault: (null)

    YYYY-MM-DDT04:01:17.069Z warning vpxd[09534] [Originator@6876 sub=Vmomi] [FdmClientAdapter] FDM service on host esxi.vsphere.local is not ready.

    YYYY-MM-DDT04:01:17.069Z error vpxd[09534] [Originator@6876 sub=Vmomi] Failed to login on host; <</hgw/host-####>, /fdm>, N7Vmacore4Http13HttpExceptionE(HTTP error response: Service Unavailable)

  • When connecting directly to the affected ESXi hosts, the vmkernel.log shows storage-related errors such as:

    • PDL (Permanent Device Loss)

    • Volume is busy


      YYYY-MM-DDT02:42:34.296Z In (182) vmkernel: cpu70:2177742) PowerPath: Path vmhba2: CO: T21:L15 Inquiry Pirp Failed
      YYYYMM-DDT02:42:34.296Z In (182) vmkernel: cpu59:2177745) PowerPath: Path vmhba2: CO: T21: L24 Inquiry Pirp Failed
      YYYY-MM-DDT02:42:34.299Z Al (177) vmkalert: cpu33:2098033) ALERT: PowerPath: E####: MpxEsxVolOpenDevice: naa. 68#############l###### Volume is busy. regState 2 devState 0 Volume Open failed.
      vmkernel: cpu59:2177745) PowerPath: Path vmhba2: CO: T21: L6 Inquiry Pirp Failed

       

  • Commands such as df -h and esxtop take an unusually long time to execute on the affected ESXi hosts.

Environment

VMware vCenter server 8.0

Cause

This issue occurs when multiple ESXi hosts experience storage issues, causing the host management agents to become unresponsive. As a result, vSphere HA continuously attempts to configure HA agents on the affected hosts, which overloads the vpxd service and causes it to become unresponsive.

Resolution

  • Identify and resolve the underlying storage-related issues on the affected ESXi hosts (for example, PDL conditions or HBA-related errors).
  • Ensure that the ESXi hosts are stable and no longer reporting storage or connectivity errors.
  • Restart the vpxd service on the vCenter Server once the host-level issues are resolved.