Dates are missing from the Analyzer
search cancel

Dates are missing from the Analyzer

book

Article ID: 424339

calendar_today

Updated On:

Products

Information Centric Analytics

Issue/Introduction

Beginning on or shortly after January 1st of any year after 2025, values equal to dates in the current year are missing from the Analyzer when using any date dimensions. This can produce unexpected results in the Analyzer.

For example, if you have created a view that displays the total count of endpoint agents filtered by the Computer Endpoint Last Activity Date Range dimension and the selected range initially spanned dates in 2025, the count of agents will decrease each day after January 1, 2026 as more dates from 2025 drop out of the range.

Environment

Release : 6.x

Component : Analyzer

Cause

The general portal setting 'The Last Year Reflected in The Date Dimension' is set to the year 2025.

Resolution

  1. Set the general portal setting The Last Year Reflected in The Date Dimension to a year in the future (for example, 2035) and click the Save button.
  2. Open SQL Server Management Studio (SSMS)
  3. Connect to the Database Engine hosting the RiskFabric relational database
  4. From the File menu, select New > Query with Current Connection

    A new query editor window opens

  5. Copy the following statement and paste it in the new query editor window:
    EXEC RiskFabric.dbo.spInitialize_DateDim;
  6. Execute the statement by pressing the F5 key, clicking the Execute button in the SQL Editor toolbar, or selecting Execute from the Query menu
  7. Allow the nightly RiskFabric Processing job to run (or manually start the job)