IDS_INVALID_RESPONSE error on Protection Engine Console
search cancel

IDS_INVALID_RESPONSE error on Protection Engine Console

book

Article ID: 424297

calendar_today

Updated On:

Products

Protection Engine for NAS

Issue/Introduction

After completing the installation, the customer observed the following error in the Symantec Protection Engine (SPE) console under Monitor > Views > Resources:

An error occurred
IDS_INVALID_RESPONSE

CmafUI.log will show below entries

2025-11-26 15:44:01,381 [9] DEBUG Symantec.Cmaf.SettingsManager.Client.RequestProxy - ProcessResponse Entering..
2025-11-26 15:44:01,382 [9] INFO  Symantec.Cmaf.SettingsManager.Client.ServerResponseFormatter - Server response FAILED: IDS_INVALID_RESPONSE
2025-11-26 15:44:01,384 [9] DEBUG Symantec.Cmaf.SettingsManager.Client.RequestProxy - ProcessResponse Exiting..
2025-11-26 15:44:01,384 [9] DEBUG Symantec.Cmaf.SettingsManager.Client.RequestProxy - SendSubsequentRequest Entering..
2025-11-26 15:44:01,384 [9] DEBUG Symantec.Cmaf.SettingsManager.Client.RequestProxy - SendSubsequentRequest Exiting..
2025-11-26 15:44:01,384 [9] DEBUG Symantec.Cmaf.SettingsManager.Client.RequestProxy - SendRequest Exiting
2025-11-26 15:44:01,384 [9] INFO  Symantec.Cmaf.SettingsManager.Client.RequestProxy - Setting transfer request is sent successfully
2025-11-26 15:44:01,384 [9] DEBUG Symantec.Cmaf.SettingsManager.Client.RequestProxy - StartRequestAsync Exiting
2025-11-26 15:44:01,384 [11] DEBUG Symantec.Cmaf.SettingsManager.Client.RequestProxy - StartRequests Exiting
2025-11-26 15:44:01,384 [11] DEBUG Symantec.Cmaf.SettingsManager.Client.RequestProxy - Execute Exiting
2025-11-26 15:44:01,384 [11] DEBUG Symantec.Cmaf.SettingsManager.Client.SettingsWorker - Received remote responses, count=1
2025-11-26 15:44:01,384 [11] INFO  Symantec.Cmaf.SettingsManager.Client.SettingsWorker - ExecuteDeployRetrieve Exiting
2025-11-26 15:44:01,384 [11] DEBUG Symantec.Cmaf.SettingsManager.Client.SettingsWorker - Exiting
2025-11-26 15:44:01,390 [Main UI Thread] WARN  Symantec.Cmaf.UI.Views.SMSUIControlView - Settings transfer error for view ResourceConsumption: IDS_INVALID_RESPONSE
2025-11-26 15:44:05,542 [Main UI Thread] INFO  Symantec.Cmaf.UI.FormSMSUI - Symantec Cmaf Common UI Closing....

Environment

SPE 9.3.0
Windows Server OS

Cause

This is happening due to SPE server sending blank string in response to rest API request for GET_RESOURCECONSUMPTION.

The difference between the attribute when SPE server is preparing the response also causes the issue. The response code is sent as 200 but due to the empty data being returned, the UI ends up throwing the error.

Resolution

Currently there is no workaround available for this issue as it is coming straight from the SPE server.
A fix will be released with SPE 9.3.1 version.