Veeam backup failed with error "Failed to open VDDK disk" in vSAN cluster
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Veeam backup failed with error "Failed to open VDDK disk" in vSAN cluster

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Article ID: 424240

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Updated On:

Products

VMware vCenter Server

Issue/Introduction

1. Veeam Backup jobs fail during the data transfer phase with one of the following similar errors:

Processing <vm-name> Error:Failed to open VDDK disk [Datastore] <vm-name>.vmdk (is read-only mode - [true]) Logon attempt with parameters [VC/ESX:<esxi-host>];Port:443;Login:[[email protected]]; Snapshot mor:[snapshot-####];Transports:[nbd];Read Only;[true] failed because of the following errors:Failed to open disk for read.Failed to upload disk 'vddkConnSpec>' Agent failed to process method {DataTransfer.SyncDisk}.

2. It succeeded to create and consolidate snapshots from vSphere UI.

Environment

Veeam backup proxy (Virtual Machine)
VMware vSAN 8.x

Cause

The backup fails when the proxy cannot access the VM’s virtual disks. In vSAN environments, this is frequently caused by a HotAdd (Virtual Appliance) transport failure, where the Proxy VM is unable to mount the disk due to stale disk locks or improper proxy placement. 

Resolution

To engage the backup vendor Veeam for further troubleshooting.