"Data Collection failed due to an error. Please wait for some time." for NSXT Datasource adding in GUI due to stale entry for NSXT Latency statistics profile
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"Data Collection failed due to an error. Please wait for some time." for NSXT Datasource adding in GUI due to stale entry for NSXT Latency statistics profile

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Article ID: 424173

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Updated On:

Products

VCF Operations for Networks

Issue/Introduction

  • GUI shows error under account and datasource page for added NSXT Manager. Error seen is Data Collection failed due to an error. Please wait for some time.

    See screenshot below:



  • Collector support bundle logs at location /var/log/arkin/collector/ shows below error/exceptions for NSXT latency statistics profile.

    2025-11-10T22:42:48.620Z ERROR dataprovider.utils.HttpUtils NSXT_########.##.####.local_Config_OpMgr-0 checkStatusAndThrow:41 API /policy/api/v1/infra/latency-profiles/vRNI-Latency_Stat_Profile_RF######OA== error response {
      "httpStatus" : "BAD_REQUEST",
      "error_code" : 500045,
      "module_name" : "Policy",
      "error_message" : "An object with the same path=[/infra/latency-profiles/vRNI-Latency_Stat_Profile_RF######OA==] is marked for deletion. Either use another path or wait for the purge cycle (max 5 minutes) for permanent removal of the object."
    }
    2025-11-10T22:42:48.621Z WARN common.utils.CommonUtils NSXT_########.##.####._Config_OpMgr-0 logException:2555 Unable to fetch data from /policy/api/v1/infra/latency-profiles/vRNI-Latency_Stat_Profile_RF######OA==
    java.util.concurrent.ExecutionException: com.vnera.dataproviders.core.common.impl.dataprovider.utils.exceptions.HttpException: Could not get response for /policy/api/v1/infra/latency-profiles/vRNI-Latency_Stat_Profile_RF######OA==, status 400
    2025-11-10T22:42:48.621Z WARN nsxt.tasks.NSXTLatencyStateWatcher NSXT_########.##.####..local_Config_OpMgr-0 process:147 Error while processing NSXT Latency: DP ID NSXT_########.##.####.local, message Unable to get/create profile


Environment

  • VCF Operations for Networks 6.13.0
  • VCF Operations for Networks 6.14.0
  • VCF Operations for Networks 6.14.1
  • VCF Operations for Networks 9.0.0

Cause

This is a known issue which usually occurs when there is a discrepancy in NSX-T latency statistics profile causing stale entry, which usually happens due to one of below or a combination of below activities:

  • During movement or migrations of NSX datasources between collector VMs.
  • The respective NSX datasource has been enabled and disabled using GUI toggle.
  • Latency metric has been unchecked and check multiple times from the GUI.

Resolution

Issue is with NSX-T latency statistics profile stale entries which needs to be cleaned up using script(s) available with support team.

If you believe you have have encountered this issue then to investigate this further 

  1. Open a support case with Broadcom Support mentioning this KB number to review your VCF Operations for Networks deployment. For more information, see Creating and managing Broadcom support cases. 
  2. Generate support bundle for Aria Operations for Networks collector from GUI, see steps mentioned in KB