"Data Collection failed due to an error. Please wait for some time." for NSXT Datasource adding in GUI
search cancel

"Data Collection failed due to an error. Please wait for some time." for NSXT Datasource adding in GUI

book

Article ID: 424171

calendar_today

Updated On:

Products

VCF Operations for Networks

Issue/Introduction

  • GUI shows error under account and datasource page for added NSXT manager. 
  • Error seen is Data Collector failed due to an error. Please wait for some time.

    See screenshot below:


Environment

  • Aria Operations for Networks 6.13.0
  • Aria Operations for Networks 6.14.0
  • Aria Operations for Networks 6.14.1
  • VCF Operations for Networks 9.0.x

Cause

This is a known issue which usually occurs when there is a discrepancy in different NSX-T latency profiles which usually happens due to one of the below or combination of below activities:

  • During movement or migrations of NSX datasources between collector VMs.
  • The respective NSX datasource has been enabled and disabled using GUI toggle.
  • Latency metric has been unchecked and check multiple times from the GUI.

Resolution

There are multiple reasons for this issue to occur, see below mentioned KBs respectively for the resolution.

Issues with NSX Latency profile state entries which needs to be cleaned up using script(s) available with support team. 

If you believe you have have encountered this issue then to investigate this further 

  1. Open a support case with Broadcom Support mentioning this KB number to review your VCF Operations for Networks deployment. For more information, see Creating and managing Broadcom support cases. 
  2. Generate support bundle for Aria Operations for Networks collector from GUI, see steps mentioned in KB