SDDC upgrade precheck fails during ESXi host checks with error message VM faults in EMM dry run
search cancel

SDDC upgrade precheck fails during ESXi host checks with error message VM faults in EMM dry run

book

Article ID: 424149

calendar_today

Updated On:

Products

VMware SDDC Manager

Issue/Introduction

  • SDDC upgrade precheck fails during ESXi host checks with error message

    VM faults in EMM dry run

  • Remediation of the error shows

    This operation would violate a virtual machine affinity/anti-affinity rule

  • Hosts can be manually placed into maintenance mode sequentially from vCenter by selecting the "Ensure Accessibility" option.
  • In the Summary tab of the affected ESXi host, the following error is seen:

    vSphere HA reports that an agent is in the Agent Unreachable state

Environment

VMware SDDC Manager 5.x

Cause

vSphere HA agent failures on specific hosts prevent VM migration to those hosts. When other hosts enter maintenance mode, VMs may breach host affinity rules (e.g., VMs must reside on separate hosts).

Resolution

To resolve the precheck failure, restore the health of the vSphere HA agents and ensure that the cluster has enough flexibility to satisfy VM affinity rules during the maintenance transition

  • Reconfigure vSphere HA on Affected Hosts:
    1. Log in to the vSphere Client.
    2. Navigate to the affected ESXi host within the cluster.
    3. Right-click the host and select Reconfigure for vSphere HA.
    4. Wait for the task to complete and ensure the "Agent Unreachable" alarm clears from the Summary tab.
  • Re-run SDDC Manager Prechecks:
    1. Return to the SDDC Manager UI.
    2. Navigate to the Inventory > Workload Domains
    3. Click on the Update/Patches tab and click Run Precheck again to verify the "VM faults in EMM dry run" error is resolved.