Reinstallation of Secondary Server is in error : Integrations of the products has failed
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Reinstallation of Secondary Server is in error : Integrations of the products has failed

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Article ID: 423990

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Updated On:

Products

CA Service Management - Service Desk Manager CA Service Desk Manager

Issue/Introduction

Reinstallation of a Secondary Server is in error 

"Integrations of the products has failed, for the below tasks:
Restart CA Service Desk Manager Services."

 

In C:\Program Files (x86)\CA\Service Desk Manager\log\configure.log we could see this :

12/31 13:37:38.137 INFO  ConfigThread.java      549 Executing task# 3, task name : Configure Tomcat integration
12/31 13:37:38.137 INFO  Task.java              214 Running: Configure Tomcat integration
Exception in thread "ConfigThread: Configure Tomcat integration" java.lang.NullPointerException
at com.ca.ServicePlus.configui.tasks.InstallTomcatTask.run(InstallTomcatTask.java:111)
at com.ca.ServicePlus.wizard.task.Task.start(Task.java:215)
at com.ca.ServicePlus.configui.ConfigThread.run(ConfigThread.java:550)
12/31 13:37:38.138 INFO  TaskMediator.java      184 Configuration has completed successfully.

Environment

Service Desk Manager 17.4

Cause

Rows in tables for previous installation of the secondary server are still present in SQL tables al_cdb_configurationparameters and al_cdb_componentinstallstate
This is causing a conflict during reinstallation of the secondary server

Resolution

  1. In database mdb execute these SQL Queries :

    select * into al_cdb_configurationparameters_backup_20251219 from al_cdb_configurationparameters
    select * into al_cdb_componentinstallstate_backup_20251219 from al_cdb_componentinstallstate
    delete from al_cdb_configurationparameters where machinename='<SECONDARYSERVERNAME>'
    delete from al_cdb_componentinstallstate where machinename='<SECONDARYSERVERNAME>'

    These queries do a backup of tables al_cdb_configurationparameters and al_cdb_componentinstallstate
    and remove rows for secondary server <SECONDARYSERVERNAME> (replace this by the hostname of the secondary server).


  2. On secondary server uninstall partially installed SDM product

  3. Try again the installation.