Cannot complete the configuration of the vSphere HA agent on the host. "Applying HA VIBs on the cluster encountered a failure". failed installing HA component on the host: host-####. An internal error occurred while staging/remediating the host.[root@ESXi_FQDN] df -hVmFileSystem: Slow refresh failed: Cannot open volume: /vmfs/volumes/########Error when running esxcli, return status was: 1Errors:Error getting data for filesystem on '/vmfs/volumes/#########' : Cannot open volume: /vmfs/volumes/#########, skipping.VMware vCenter Server 8.x
The issue occurs because the LUN presented to the ESXi host is not in a ready state or has storage inconsistencies, preventing the FDM agent from installing or updating.
Rescan the storage adapters on the affected ESXi host to refresh datastore visibility.
Refer to the article: Performing a rescan of the storage on an ESXi host
df -h command on the ESXi host and verify if the presented datastores are listed.Disable vSphere HA at the cluster level.
Re-enable vSphere HA to trigger a fresh HA configuration.
Refer to the article: Disabling and enabling VMware vSphere High Availability (vSphere HA)