[VMC] NSX login failure due to error: Unauthorized Error Code 98
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[VMC] NSX login failure due to error: Unauthorized Error Code 98

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Article ID: 423851

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Updated On:

Products

VMware Cloud on AWS

Issue/Introduction

  • VMC on AWS organization members are unable to log in to the Cloud NSX Manager via both non-local account links. 
  • This affects members when logging in with accounts other than the local NSX Manager administrator account (cloud_admin). 
  • Error seen when the log in fails:

{"module_name":"common-service","error_message":"Unauthorized","error_code":98}

Environment

VMC on AWS

Cause

  • This can affect members when they are Organization Owners or Members of multiple organizations. 
  • The error is seen when the default organization is set to a different organization than the NSX Manager attempting to be accessed. 

Resolution

The issue is resolved by verifying the organization and service roles and updating the default organization to the organization that includes the NSX Manager. 
  • To verify the account roles, navigate to "My Account" in the Cloud Services Console and review both the "Organization Roles" and "Service Roles". 
  • Once the account roles have been verified, update the default organization to the organization that includes the NSX Manager being accessed. 
  • This can be completed by following the process documented here: How to set a Default Organization in the Cloud Service Console
  • After the default organization has been verified or updated, attempt the login again. 
  • Open a support ticket with the VMC on AWS Global Support team if the login is still failing. 
  • Include the following when opening these types of tickets:
    • Organization ID
    • SDDC ID
    • Account being used for login
    • Error seen

Additional Information